[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_content.php on line 678: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_content.php on line 678: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/viewtopic.php on line 1623: sizeof(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_content.php on line 678: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_content.php on line 678: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/viewtopic.php on line 1623: sizeof(): Parameter must be an array or an object that implements Countable
Nissan Largo Friends • View topic - New member joining, needing advice please.

New member joining, needing advice please.

Say hello to the group here and let us know whereabouts you are.

New member joining, needing advice please.

Postby tim_p » 03 Aug 2019, 12:42

Hi all,

I have been a nissan largo owner for the best part of 5 months now with pretty much trouble free motoring, now it would appear that is all about to change.
I managed to change out all the drive belts to remedy an extreme noise from one of them at idle, it turned out to be in the end a missing bolt from the bottom bracket of the alternator and the position bracket that bolts to the engine casing was completely snapped in half. The belts semmed to be fine just a bit old so changed them anyway, what i need now is some advice on the changing of the alternator as in the middle of all this going on i have a constant battery light and nothing in the way of charge going to the battery via a multimeter, it appears to be hosting some kind of oil pump and i was wondering if it is at all possible to change out the alternator whilst leaving the oil pump connected as i really don`t want to remove it or cause any other undue issues if possible.

Any help or advice on this would be great as our local mechanic seems a bit shy of getting involved with this vehicle :shock:

Vehicle in question is 95 Largo 2.0 td 2wd
User avatar
tim_p
dipstick
dipstick
 
Posts: 2
Joined: 03 Aug 2019, 09:54
Has thanked: 0 time
Have thanks: 0 time
Fuel: Diesel
Drivetrain: 2WD
Seats: 7 Seats
Roof: Glass Top
Trim:
Mods:

Re: New member joining, needing advice please.

Postby Cueball » 18 Aug 2019, 14:50

Hey. Welcome to the forum. The pump on the back is the vacuum pump.
Image
User avatar
Cueball
Site Admin
 
Posts: 3821
Joined: 27 Apr 2010, 22:41
Location: Barrow-in-Furness, Cumbria, UK
Has thanked: 116 times
Have thanks: 135 times
Fuel: Diesel
Drivetrain: 4WD
Seats: 7 Seats
Roof: Tin Top
Trim:
Mods:


Return to New Members Introduce Yourself

Who is online

Users browsing this forum: No registered users and 0 guests

cron